Not able to create new repo

After creating an initial demo repo to play around with Prismic I'm trying to create a new repo to work on a new app. everytime i add the new name i get this error: :heavy_multiplication_x: Creating new repository flowrise-demo-app ...
→ Failed to create repository flowrise-demo-app
Error: Failed to create repository flowrise-demo-app
at PrismicRepositoryManager.create (/Users/odeliafinkelstein/.npm/_npx/b6923b01b288b666/node_modules/@slicemachine/manager/dist/managers/prismicRepository/PrismicRepositoryManager.cjs:125:13)
at process.processTicksAndRejections (node:internal/process/task_queues:95:5)
at async Task.task (/Users/odeliafinkelstein/.npm/_npx/b6923b01b288b666/node_modules/@slicemachine/init/dist/SliceMachineInitProcess.cjs:625:11)

Likewise! I just found this out while trying to help another forum post out. Must be a bug that found its way into 1.17.

In a pinch, make one on the web, then you can hook into it if it already exists. Hope that helps.

Any luck @odelia.finkel ? I tried again today after I saw new slicemachine version. I'm still unable to create new repositories via the slicemachine/init. I'm considering trying an older version to see if it works.

Ok so I got past my not being able to create repos. I ran

prismic logout
prismic login

Despite slicemachine/init showing that I was logged in, it apparently didn't like my status.

I will now test building.

Hi @nf_mastroianni,

Welcome to the community!

Thank you for the bug report. We also identified on our side a problem with the authentication, specifically to create a repository with the init.

We are currently fixing the bug: fix(init): Fix failed to create repository error in init by xrutayisire · Pull Request #1179 · prismicio/slice-machine · GitHub
It's the equivalent of what you're doing, logout to flush the stale authentication and login again.

It should be released next week :slightly_smiling_face:

Thank you,
Xavier

3 Likes

Hey Neil,

Works on my end now!

2 Likes