Prismic changes aren't updating on my Gatsby site (Webhook enabled)

I've been experience some strange issues with Prismic as of late. I'm trying to post new blogs and make small edits to pages but the changes aren't appearing on my Gatsby site. The site is using webhooks to deploy on Netlify whenever a change occurs in Prismic.

The best example that this isn't working right is the blog page.

The most recent blog post titled "Levelling Up: Why BIN Mismatch Data Shouldn't Be Your Only Fraud-Fighting Tool" shows up in the blog listing but when you click on it I get a 404 error. So it's strange that the post is appearing in the list but the actual post won't load.

I also tried making a small update to the about page and it never showed up. I have tried running "gatsby clean" and rebuilding from fresh and still experience the same issues. I know there have been some issues with "gatsby-source-prismic-graphql" as of late, and that's the plugin I'm using.

Does anyone have any thoughts?

Hi, can I get some help with this from the technical support team please? My content is time sensitive and I could use some assistance.

Hi Christina,

Welcome to the Prismic community.

As you know Prismic doesn't recommend the gatsby-source-prismic-graphql plugin and we highly recommend migrating to gatsby-source-prismic

And here is an article that shows how to migrate as well as the full documentation of gatsby-source-prismic

If you still want to continue with the none maintained gatsby-source-prismic-graphql we at least advise you to migrate to our fork of the plugin @prismicio/gatsby-source-prismic-graphql.

And so regarding the issue you are facing, I will try to investigate the issue as far as I can, but I can't guarantee we will be able to find a solution.

To do so, I have some questions, first of all, have you tried to investigate if the webhook triggers your project rebuild in Netlify logs? and if there is an error there?

Looking forward to your reply,

Hi Fares,

I figured out the problems. I wasn't specifically setting a limit on how many blog posts I wanted Prismic to get, so it seems like the default limit is about 20. I changed the limit and managed to get what I wanted done.

I'm aware that gatsby-source-prismic-graphql is no longer supported but haven't had the time to integrate the new plugin yet. Maybe I'll try your forked version of it in hopes that I don't have to overhaul the entire site to use gatsby-source-prismic.

Thanks for your response

1 Like

Great, thanks for letting us know.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.