Prismic CLI Login over SSH

The CLI seems to have changed, I used to be able to put my email and password in and it logged in, now it wants to open the browser.
The problem is I work on a remote development box, so my terminal has an SSH connection to that box and when it says that it's opening the browser, nothing happens.

Hi Ben,

Welcome to the community!

I've reached out to the devs to get more information about this. Once I have more info I'll update you here.

Thanks.

Hi Ben,

Keeping the ability to login with email + password was discussed, but we decided to deprecate it (I would like to keep it) but it's a very niche use case.

Although there is something that I would like to try and to see if it works :slight_smile:

First of I'm assuming you're using linux,
Install a console based browser here's a small selection List of applications - ArchWiki),
pick one that supports javascript like browsh or elinks (disabled by default)

the set that as you're default browser (assuming browsh https://www.brow.sh/
)
xdg-settings set default-web-browser browsh

Then try to login again, and it should open a console based browser :slight_smile:

if you do try this, can you let me know it it goes?

Best,
Marc

This thread has been closed due to inactivity. Flag to reopen.