Twitter embed not always displaying on Prismic in Chrome

Hello all, we are are having trouble with tweet embeds where, while in Chrome, twitter embeds are not displayed fully as twitter 'cards'. This is not the case in incognito, on mobile or using other browsers - only desktop Chrome. Clearing the cache, resetting flags, and disabling extensions does not resolve the issue.

The page in question is: Here's who's appearing on the this series of Who Do You Think You Are? UK | Blog | findmypast.co.uk.


Any help greatly appreciated.

Hi @smilne,

Thanks for reaching out,

I have tested this, and on the browser, I've tested chome Version 101.0.4951.64 (Official Build) (x86_64), and incognito mode, it shows the Twitter card properly know it takes a bit longer to appear to see the following screenshot.

Please let us know if you need any further assistance,
Fares

Thanks Fares, the problem is persisting for us and will keep invesitigating.

Hi Fares, after reviewing it some more this issue is replicated across various machines on different browsers in incognito and standard windows. In many cases the problem can be addressed by clearing cookies but in some it can't, while in incognito windows the issue is less prevalent but still persists in some cases.

We are also receiving an error: Failed to load resource: net :: ERR_BLOCKED_BY_CLIENT https://platform.twitter.com/widgets.js on occasion.

Hi @smilne,

It is essential for us to be able to reproduce the issue to be able to investigate it.

I have done multiple tests, and the Twitter embed is always working for me; if you can share some details about the browser versions that have the issue, OS, and location so that we try to reproduce it again.

Here are some of the tests I've don using Brave, chrome and Safar again and all worked:






Thanks Fares,

The issue seems to apply across a number of different browsers under different conditions. Below is a sample, but seems to hold for different machines attempting to load the page.

Does the tweet display correctly? -

  • Chrome(Version 101.0.4951.64 (Official Build) (arm64)) on Mac and Windows: standard - sometimes (when cookies are cleared), incognito - always.
  • Firefox(100.0.2 (64-bit)) on Mac: standard - sometimes (cookies or not), private - sometimes(cookies or not)
  • Safari(Version 15.4 (17613.1.17.1.13)) on Mac: standard - always, private - always
  • Edge(Version: 100.0.1185.39) on Windows: standard - sometimes (when cookies are cleared), incognito - always

Seemingly the same HTML is being passed to the DOM, but being rendered differently in the cases of correct display and incorrect display.

Many thanks

1 Like

Update:

This issue can be replicated, under the same conditions as above for other article pages and with other kinds of embed e.g. Facebook and tweets containing images, gifs and text only

Hi @Fares, is it possible to get n update on this issue/a fix? Keen to have social embeds displaying correctly in all contexts. Please let me know if there's any further info that would help with investigating. Many thanks

Hi @smilne,

I apologize, but I havn't been able to reproduce this issue; I have tried the same version of os and versions of the browser you have indicated, but all works fine.

One way that can be a bit complicated and needs some expertise is to try to try to reproduce on a virtual machine hosted online. Once you are able to reproduce it, please share this VM with us, and we will investigate.

Otherwise, it is tough to reproduce on our side and so investigate the issue.

Thanks for your understanding.

Thanks @Fares, can I double check that it isn't reproduced in incognito/private Firefox? It seems to completely consistently not display when using that browser in a private window. Thanks

Hi @smilne

Thanks for pointing out, yes true in Firefox it seems consistently not showing in incognito

I will investigate and let you know.

1 Like

Hi @Fares, Just wondering if your team have gained any insight into why this might be happening? Thanks