Gatsby prismic theme command does not create a repository

So I've tried following this tutorial; https://user-guides.prismic.io/en/articles/2933292-sample-blog-with-api-based-cms-gatsby-js

I'm currently using the primsic-cli@3.7.11 and executed the following command;

prismic theme --theme-url https://github.com/prismicio/gatsby-blog --conf prismic-config.js

This command however does not create a corresponding repository, I'm missing some lines in my terminal.

prismic theme --theme-url https://github.com/prismicio/gatsby-blog --conf prismic-config.js
We are checking the theme integrity
Let's get to it!
? Name your prismic repository:  xxx
? Local folder to initalize project:  xxx
Initialize local project
Running npm install...

There's a line missing here which tells me I can visit the new repository online. Does anyone happen to know why this command fails?

Thanks in advance!

Hello,

Thanks for posting us.

I checked this theme command and it's creating repository in Prismic dashboard. Can you please check repository in your dashboard here?

Let me know if you have any issue.

Thanks,
Priyanka

@Priyanka thanks for your reply, I just tried a fresh install to verify; I used the following tutorial; https://prismic.io/docs/gatsby-tutorial-1-launching-the-project

I don't see any repository being created, I get the following in my terminal;

C:\prismic>prismic theme https://github.com/prismicio/gatsby-getting-started-tutorial --ignore-conf
? URL of your theme (zip/github):  https://github.com/prismicio/gatsby-getting-started-tutorial
We are checking the theme integrity
Let's get to it!
? Name your prismic repository:  test-the-tutorial
? Local folder to initalize project:  test-the-tutorial
Initialize local project
Running npm install... 

Your project is ready, to proceed:

Go to the project folder : cd test-the-tutorial

There is no repository to be found in my dashboard, with best regards,

Kevin

@kevindamstra it may be possible that you’re logged in to a different Prismic account because I tried it again and it's working.

Can you please run these command on your terminal :- prismic logout and then prismic login and enter your credentials from which you access repository. After that again run prismic theme command and go to your Prismic dashboard and refresh this page.

Can you please tell me what version of CLI are you using, you can check it through prismic --version.

Give this to try and let me know.

@Priyanka Thank you! Logging out of the prismic cli seems to be the solution, now I get to sign in to my account and the repository is created!

With best regards,

Great! Happy to help. Don't hesitate to reach out us if you have any doubts.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.