Preview cookie not available on Google Chrome

Hi,

Our team is having issues previewing on Google Chrome. We debugged this and it seems that the io.prismic.previewSession cookie is being set without the SameSite attribute causing it to be rejected in the latest version of chrome and safari. This may be a regression from the fix here.

I added a screenshot of my cookies to this github issue where you can see the SameSite attribute is not being set for that cookie. You can also see there is a cookie being set with the key=SameSite and value=None which appears to be a mistake.

Let me know if you need any additional information or have any information about a fix.

Thank you!
Vivian

Hello Vivian, could you please provide me with the version of chrome you're previewing with and the URL of your repository? (You can send that to me in a private dm). We're currently making tests about similar issues reported in the lasts hours.

Thanks a lot

Hi Paulina,

Thank you for taking a look into this! I'm seeing this issue with Chrome Version 86.0.4240.198.

Also we tested changing this chrome flag - chrome://flags/#same-site-by-default-cookies to disabled and that resolves this issue but it is not as secure so we don't want to use that as a long term solution.

I will also send along the repository URL in a private DM.

Thanks again and let me know if you need anything else!
Vivian

1 Like

Hey Vivian, thank you for the details. There seems to be an issue with previews for repositories linked to Slicemachine. It seems to be on Chrome and we think it's to do with a cookie policy issue, we rolled out a fix previously on other groups. We're looking in to it and we'll update you here once we know more.

Thanks.

1 Like

Hi Paulina,

Thank you for the feedback!

1 Like

I have the same problem. I hope it will be solved soon...

Hey everyone, just to let you know that we've moved this to the priority list of tasks. So It'll be tackled in the next round of fixes. We'll keep you all posted about the status of this in this same post.

Thanks