Shopify Integration Fields No Longer Updating

Hey Phil,

Thanks for getting back to me. I've attached two screen recordings below showing you the Shopify products and me searching for the product in our Prismic integration field.

I've uploaded the videos to Dropbox as they were too large to upload in this message. You can access them here. I've also included a screenshot of the integration field configuration with the creds blurred out.

Let me know if there's anything else I can do to help / investigate.

Thanks!

OK, we've investigated and maybe identified a bug on our side for the Shopify connector. It seems at the moment only the first page of 50 items is synced whereas you have 72 items in your catalog atm.

I'm logging it as a bug and the team will triage it and let me know when they can get on top of it. Unfortunately, I don't have any workaround for you now, but I'll let you know as soon as this is fixed.

Hey Phil,

Thanks for getting back to me. Could you let me know as soon as it's fixed so I can inform the client? The issue is stopping us from launching the whole website so it's a bit of a major roadblock to say the least.

Thanks!

I will as soon as I get more info.

Thank you for your patience.

Hey Kieran,

So, the word from the team for now is that they won't be able to fix this until next week. When is your client's launch planned?

Hey Phil,

Thanks for letting us know and apologies for the delay in getting back to you. I think it's tentatively planned for some point over the next couple weeks, so if the team can get it fixed next week that would be perfect.

Thanks so much!

1 Like

We are observing that from last week Prismic and shopify products are not in sync, we are missing some Shopify products in prismic searches.

  • At our end we made sure that we are setting right integration fields, and according to integration fields status it also syncing every 30 mins.
  • Also it was working perfectly fine from a long time now, so there must no shopify or config related issues.
  • Is there any other way to debug the issue?

Hey everyone,

Because of some unforeseen circumstances, we didn't get to this as soon as we wanted, but we will get on top of it this week and let you know when it's fixed.

Thank you for your patience and understanding.

Hey Phil,

Thanks for the update!

1 Like

Hi @communication ,

So we have a fix ready and we're testing it, but before we push the fix we can now see in production 72 items synced in your repo which matches the 72 items in your catalog. Can you confirm you are still seeing the issue?

Thanks.

Hey Phil,

I've just had a look and there's 72 products in my Shopify, but only 42 in my Shopify catalogue in Prismic, so yeah I'm still currently seeing the issue.

Thanks!

OK, I've passed this to the team, we'll get on it right away

Hi @here,

We deployed a fix yesterday - and the issue should be resolved. Sorry about the delay.

Hey Phil,

Thanks for letting me know. I've just logged in and taken a look and it's now syncing 50 products, but when I search for some products that are live in Shopify, I'm still not seeing them in Prismic. Is there anything else I should try on my side of things?

Thanks!

You shouldn't have to do anything on your side. I'll confirm with the team.

This should be good now.

Hey Phil,

Thanks for sorting that out so quickly with the team. I've just tested now and I can confirm it's working as expected.

Thanks again, really appreciate it!

1 Like

Happy to hear :slight_smile:

1 Like

Thanks Phill, Looks like its resolved at our end too.

1 Like