Shopify Integration Fields No Longer Updating


My name is Kieran, I'm posting on behalf of my client as I'm the developer working on their website.

We've started running into an issue with the integration field this week where it doesn't seem to be syncing the full product catalogue from Shopify anymore. It's worked fine since we've been using it (around 18 months now), but my client is now reporting that products that were previously added to one of our custom types have disappeared. And when I search for products that are visible in Shopify, they don't appear. It looks like the integration field is only outputting 50 products, rather than the roughly 100 products in their catalogue.

I've gone through all the credentials and everything is correct, and there's no errors reported when you view the integration field panel in Prismic. I've also gone through and updated all the permissions in our Admin app on Shopify so they at least have read access. There's some Admin api fields which I don't have access to in Shopify due to permissions such as 'read_assigned_fulfillment_orders', but I'm assuming this field isn't necessary in order to make the integration fields work?

Here's our Prismic repo:

If you could CC my email address ( into any correspondences that would be great.

Let me know if there's any other information I can supply,


Hi Kieran,

I have checked all the logs on our side and can't find any errors. It also sounds like you have investigated all the points I would suggest.

So to help me out can you send me a screen recording of the problem and maybe a screenshot of of your configuration in repo settings?

With this I can dig deeper with the team.


Hey Phil,

Thanks for getting back to me. I've attached two screen recordings below showing you the Shopify products and me searching for the product in our Prismic integration field.

I've uploaded the videos to Dropbox as they were too large to upload in this message. You can access them here. I've also included a screenshot of the integration field configuration with the creds blurred out.

Let me know if there's anything else I can do to help / investigate.


OK, we've investigated and maybe identified a bug on our side for the Shopify connector. It seems at the moment only the first page of 50 items is synced whereas you have 72 items in your catalog atm.

I'm logging it as a bug and the team will triage it and let me know when they can get on top of it. Unfortunately, I don't have any workaround for you now, but I'll let you know as soon as this is fixed.

Hey Phil,

Thanks for getting back to me. Could you let me know as soon as it's fixed so I can inform the client? The issue is stopping us from launching the whole website so it's a bit of a major roadblock to say the least.


I will as soon as I get more info.

Thank you for your patience.

Hey Kieran,

So, the word from the team for now is that they won't be able to fix this until next week. When is your client's launch planned?

Hey Phil,

Thanks for letting us know and apologies for the delay in getting back to you. I think it's tentatively planned for some point over the next couple weeks, so if the team can get it fixed next week that would be perfect.

Thanks so much!

1 Like

We are observing that from last week Prismic and shopify products are not in sync, we are missing some Shopify products in prismic searches.

  • At our end we made sure that we are setting right integration fields, and according to integration fields status it also syncing every 30 mins.
  • Also it was working perfectly fine from a long time now, so there must no shopify or config related issues.
  • Is there any other way to debug the issue?

Hey everyone,

Because of some unforeseen circumstances, we didn't get to this as soon as we wanted, but we will get on top of it this week and let you know when it's fixed.

Thank you for your patience and understanding.

Hey Phil,

Thanks for the update!

1 Like

Hi @communication ,

So we have a fix ready and we're testing it, but before we push the fix we can now see in production 72 items synced in your repo which matches the 72 items in your catalog. Can you confirm you are still seeing the issue?


Hey Phil,

I've just had a look and there's 72 products in my Shopify, but only 42 in my Shopify catalogue in Prismic, so yeah I'm still currently seeing the issue.


OK, I've passed this to the team, we'll get on it right away

Hi @here,

We deployed a fix yesterday - and the issue should be resolved. Sorry about the delay.

Hey Phil,

Thanks for letting me know. I've just logged in and taken a look and it's now syncing 50 products, but when I search for some products that are live in Shopify, I'm still not seeing them in Prismic. Is there anything else I should try on my side of things?


You shouldn't have to do anything on your side. I'll confirm with the team.

This should be good now.