Unable to upload media

I am unable to upload additional media to prismic. I tried uploading 2 different jpgs and it will show a placeholder with a 0% progress bar. I tried logging out and back in; restarting the computer in case it was a cache issue, but nothing has worked.

Summary

This is for https://ridealto-staging.prismic.io/

Hi @haley.demos,

Could you share the jpeg with me so I can try uploading it on my side? (Feel free to share it in a DM.)

Thanks,
Sam

DCHero.png
Here is the img.
My hunch is its a size issue, but it is odd that there is no error message.

Do our repositories have different file/image size restrictions?

  1. ridealto.prismic.io
  2. ridealto-staging.prismic.io

Hi @haley.demos,

I don't have access to that Google Drive file to download it. Can you make the link public, or share it with me @ sam.littlefair@prismic.io?

The maximum file size is 10mb.

Sam

No worries. As there is a 10mb limit, that is the cause of the issue. I was able to upload a smaller version of the image. It confused me as I didn't receive any error msg and it appeared to freeze in the uploading state. Improving messages around this would be extremely helpful for our marketing team as they have less technical aptitude and would not know how to troubleshoot this without an error message related to the size

Do you have any recommendations for images that we use as full-page backgrounds? I am finding they are a bit grainy. I realize it is a delicate balance between quality and size. I was wondering what some of your other clients do in these situations. I want to ensure we produce the best possible website with your tools.

Kind regards,
Haley

Hi @haley.demos,

I'm glad we figured out the issue, but, I agree with you that the error message could be clearer. I'll share that with the product team.

10mb should be plenty for a full-page background image. You can make sure that you export the image at the necessary dimensions and then compress the image yourself to make sure that upload size isn't an issue. I use a tool called ImageOptim for image compression. If your images are grainy, you could try disabling Imgix's compression manually:

Some users find that the compression can degrade images slightly.

Let me know if that helps :slight_smile:

Sam

Thank you so much Sam, this information helps immensely. I’m reading up on imgix now! I’m sure I can resolve it.

1 Like

Looks like there is still no error message when hitting the 10Mb limit. I just tried to upload an image that was just over 10Mb and it just got stuck at 0% like in the original screenshot. An error message for size limits isn't difficult to achieve and would prevent production issues.

Hello @peter2

I understand that displaying an error message will be helpful. My colleague @samlittlefair has already passed this issue to our team. But it's not on their priority list for the moment. We will let you update once we get any news from the team.

Thanks,
Priyanka