Prismic closes when I save my work

I have a problem : when i save my work, automatically, Prismic log me out, and close the application. On Chrome and on Firefox. How to fix it please ? Thanks

Hi @dev42,

That's very strange. I'd like to check a few things to troubleshoot this.

  1. Could you tell me your repo name? I'll see if there are error logs associated with your repository.
  2. Could you send a screen recording of the error? Ideally with the developer tools console panel open. (In Chrome and Firefox you can open developer tools with option + command + i and then select the "Console" tab.
  3. Could you tell me if you have any network settings, like a proxy or a firewall?


Hi @samlittlefair ,
Many thanks for your answer !

  1. My repo name is "pascalepyotcom"
  2. My error message is : "invalid or missing csrf token"
  3. I desactivated my firewall and deleted my cookies and it doesn't run, except with private navigation...


@dev42, it's possible that you have a browser extension that is interefering. Could you disable all of your browser extensions and try again?


@samlittlefaire, no it doesn't run unfortunately...

@samlittlefair it is running now, many thanks !!

@samlittlefair except when I want to change picture. And I am a photographer... I am a bit desesperated...

@dev42 Could you tell me what OS and version you are using, and the versions of Firefox and Chrome that you are using? Is it possible that there's anything else in your browser — settings or plugins — that could be interfering in the editor? Also, could you share a screenshot of the error?


Hi @samlittlefair ,
I put in attachment a screenshot of the errors for Chrome and Firefox, with the versions used. And I use Windows 10.
Many thanks.

Hello @samlittlefair ,
I don't know if you can see my last message ?
To informe you, I changed today my windows version for the last one : 11. But it doesn't change anything to my problem with Prismic...
Many thanks.

Hi @dev42,

Thanks for following up. I've tried investigating, but I can't find a cause or fix, so I'm going to escalate this issue to our platform team. I'll let you know when I have an update.



You mentioned that it works in a private browser. Can you confirm that's continues to be the case? Can you upload images if you use a private browser?


@samlittlefair ,
No, no it doesn't run anymore on private browser... Before it didn't run very well...

Hi Pascale,

I can't find anything in our logs that could be causing this, so it seems like a browser issue we can't recreate on our side.

Are you using a VPN by any chance?

Can you send me a screen recording of the issue so I can pass this to our devs?


Hi @Phil ,
Thanks for your reply. I don't use VPN. For the screenshot of the issue, I sent it 23 days ago, is that you want ?

The screenshot is useful for seeing the error, but a recording of what exactly happens as you click the button would be useful as well. Thanks.

Yes I sent the screenshots of recording of what happens when I click the button. So I don't know what screenshots can I do ?...

I mean, a video of what is happening will help.

There are no errors in our logs for your repo.

The “Invalid or missing CSRF token” message means that your browser couldn’t create a secure cookie or couldn’t access that cookie to authorize your login. This can be caused by ad- or script-blocking plugins or extensions and the browser itself if it's not allowed to set cookies.

To allow this on different browsers, you can:


  1. Open Safari Preferences from the drop-down menu in the upper right corner or through Cmd + comma (⌘+,) shortcut.
  2. Click the Privacy tab and make sure that "Cookies and website data" is set to either "Always allow" or "Allow from websites I visit."
  3. Click on the Manage Website Data button to see all locally stored website data.
  4. Search for “Prismic” and remove all Prismic-related entries.
  5. Reload Safari and check Prismic.


  1. Open Chrome Settings.
  2. Scroll to the bottom and click on Advanced.
  3. In the Privacy and Security section, click the Content Settings button.
  4. Click on Cookies.
  5. Next to Allow, click Add. Type [*.] and click “Add.”
  6. Under All cookies and site data, search for Prismic, and delete all Prismic-related entries.
  7. Reload Chrome and log into Prismic.


  1. Go to Firefox's Preferences > Privacy & Security Menu.
  2. In the History section, select "Use custom settings for history" from the drop-down menu.
  3. Click on Exceptions and whitelist
  4. Scroll down to Site Data and click on Settings next to it.
  5. Search for "Prismic" and remove all shown entries.
  6. Reload Firefox and try to log in.

Hi @Phil
I tried it but it doesn't work and now I have this message : "Error while saving your changes - Click to retry". Also before I didn't have problem on my other computer but now I have the same problem as my current computer, so now I really can't use Prismic...

I really don't understand, that makes me a little crazy :sweat_smile: