Slices not showing up after pushing changes

I've pushed some changes through slicemachine but they aren't still being displayed in the dashboard. I tried to find information regarding this process in the documentation but wasn't able to find anything that could help me. I saw in one video that the changes are "pushed to github" but I'm currently working locally without using github.

Can anyone help me with this?

Prismic doesn't have access to push changes to GitHub. Maybe the warning in the console is unrelated to Slice Machine?

Is not a warning. I just saw the github reference in a video. Prismic & Slice Machine - Crash Course - YouTube

I've pushed the changes from the slicemachine and it is displayed as synced.
Yet, when I go to the dashboard to try to add the new slice it is not displayed.

I've tried starting from scratch again with minimal boilerplate for the nextjs project and I still have the same issue where I create a slice and it doesn't reflect in the dashboard.

Is it possible to contact support directly for help with this, we are currently evaluating options for a project.

Hey @Phatale, could you share a screenrecording of this?

Yes certainly.

So here's a 2 minute recording of me showing what's the issue. I am following all the steps, and I made sure the file is synced. Yet, when I end up going to the dashboard there's nothing available. I'm using the template provided in the prismic site when creating a nextjs site with minimal boilerplate.

Hi @Pau has there been any updates regarding the above behaviour?

I figured it out. I decided to create a new page to see if the change would be reflected. It worked so I checked further and saw that we have to individually add the slices to be enabled in the pages. Once I enabled the slices in the page I was able to add the slices to the respective pages in the dashboard.

I never saw any mention of it in the documents nor the tutorials, so I think that would be helpful a helpful addition.

tagging @nathanisaac056 for solution.

1 Like